Heli-X5 does not detect Joystick using PPM2USB

Installation and usage on Linux / Installation unter Linux
Post Reply
Posts: 1
Joined: 17 Jan 2015 22:51

Heli-X5 does not detect Joystick using PPM2USB

Post by mista » 17 Jan 2015 23:56

When starting helix 5.0. I always get tthe following error message:
$ ./runHELI-X.sh
Set new path for the resources: /home/michael/Downloads/tempo/HELI-X5/resources/
Set new path for the user files: /home/michael/Downloads/tempo/HELI-X5/files/
Linux plugin claims to have found 6 controllers
No Joystick found

The simulator starts nevertheless but as I have no Joystick to control it this is pointless.

Here is my system setup:
* Ubuntu 14.04, 64-bit
* Oracle Java
* Remote: Graupner MX-16 connected via PPM2USB (http://thomaspfeifer.net/ppm2usb_adapter_en.htm) + signal conditioning

Things I tested:
* the PPM2USB adapter shows up under Linux and generates 2 device nodes (event12 + js0)
* the permissions for both nodes are ok
crw-rw-rw- 1 root root 13, 76 Jan 17 19:19 /dev/input/event12
crw-rw-rw- 1 root root 13, 0 Jan 17 20:50 /dev/input/js0

* the usual test application for the joystick works
$ jstest --normal /dev/input/js0
Driver version is 2.1.0.
Joystick (thomaspfeifer.net PPM2USB-thomaspfeifer.net) has 8 axes (X, Y, Z, Rx, Ry, Rz, Throttle, Rudder)
and 0 buttons ().
Testing ... (interrupt to exit)
Axes: 0: 0 1: 0 2: 0 3: 0 4: 0 5:-29390 6: 0 7: 0

I can see the values changing when moving the controls!

I tried to use an updated libjinput from here: https://java.net/projects/jinput/downloads
Which didn't help :cry:

Then I tested heli-x 4.2 - there the joystick gets detected!
Found 11 display modes
Jan 17, 2015 11:31:37 PM net.java.games.input.ControllerEnvironment log
INFORMATION: Linux plugin claims to have found 7 controllers

Controller found: Name: thomaspfeifer.net PPM2USB-thomaspfeifer.net(thomaspfeifer.net PPM2USB-thomaspfeifer.net)
Using Stick thomaspfeifer.net PPM2USB-thomaspfeifer.net
Analog component found:x
Analog component found:y
Analog component found:z
Analog component found:rx
Analog component found:ry
Analog component found:rz
Analog component found:slider
Analog component found:rz
Name conflict found for sticks. Using numbers.
Controller configuration file not found: ~/HELI-X42/files/controller/thomaspfeifernetPPM2USB-thomaspfeifernet.xml

For 4.2 this doesn't sound too bad but I still cannot control anything, there is no menu showing up, no reaction to any input... (I expect something else is badly wrong here... I decided to focus on my issue with 5.0)
Last thing I tried was using libjinput-linux64.so from heli-x 4.2 with heli-x 5.0 => same failure (No Joystick detected).

Any idea what's going wrong here? Your help is greatly appreciated!


User avatar
Posts: 1745
Joined: 25 May 2008 16:11
Location: Germany

Re: Heli-X5 does not detect Joystick using PPM2USB

Post by Michael » 18 Jan 2015 00:48

We could try this in V6. There you can switch the jinput-lib within the program. Send me an email to join the beta test programme: info at heli-x.net


Post Reply