Ubuntu 18 and HELI-X 8

Installation and usage on Linux / Installation unter Linux
Post Reply
jvais2000
Posts: 2
Joined: 05 Mar 2019 11:39

Ubuntu 18 and HELI-X 8

Post by jvais2000 » 05 Mar 2019 11:52

Dear,
I've starting to use HELI-X 4 as an demo version and it's work perfectly.
commande: ./run-HELI-S64.sh

Now I would like to buy and install the full version and up date with the last version (HELI-X 8).
But When I do the same approach
commande: ./runHELI-X.sh

The logicie start but after selected my language the logiciel crack

Did I miss some thinks?
Last edited by jvais2000 on 05 Mar 2019 14:38, edited 1 time in total.

jvais2000
Posts: 2
Joined: 05 Mar 2019 11:39

Re: Ubuntu 18 and HELI-X 8

Post by jvais2000 » 05 Mar 2019 11:55

In the worth case, If I buy HELI-X my serial number will work with HELI-X 4 ?

User avatar
Michael
Posts: 1784
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Ubuntu 18 and HELI-X 8

Post by Michael » 05 Mar 2019 17:44

Hello,

it is likely that you have to update/improve your graphics driver. Which error messages do you get in the console?

A license is valid for 4.2 and 8.0

Michael

Elfe
Posts: 3
Joined: 16 Mar 2019 17:44

Re: Ubuntu 18 and HELI-X 8

Post by Elfe » 16 Mar 2019 18:04

Hi,
I have 2 linux boxes at different locations. The first box I used last week and it was running v8 just fine. I moved to my different box today. Unfortunatly Heli-X8 fails after the language selection like the original poster:

Code: Select all

LANG=C ./runHELI-X.sh 
handleError
SEVERE o 5:40:55 PM Uncaught exception thrown in Thread[jME3 Main,6,main]
java.lang.ExceptionInInitializerError
        at com.jme3.system.lwjgl.LwjglDisplay.createContext(LwjglDisplay.java:112)
        at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:113)
        at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:211)
        at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.ArrayIndexOutOfBoundsException: 0
        at org.lwjgl.opengl.LinuxDisplay.getAvailableDisplayModes(LinuxDisplay.java:951)
        at org.lwjgl.opengl.LinuxDisplay.init(LinuxDisplay.java:738)
        at org.lwjgl.opengl.Display.<clinit>(Display.java:138)
        ... 4 more

Exception: java.lang.NoClassDefFoundError thrown from the UncaughtExceptionHandler in thread "jME3 Main"

^C
Both boxes are running Arch linux with a pretty recent patch level. The main difference in regards to DisplayModes could be that the working one is using a GFX970 with dual screens. The not working one is a single display on a GF1060. (version 4.2 seems to be working on the second machine just fine)

Best regards
Karsten

User avatar
Michael
Posts: 1784
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Ubuntu 18 and HELI-X 8

Post by Michael » 18 Mar 2019 09:48

Can you send me via email the complete output of the console?

You might try different Java versions, sometimes there are problems with OpenJDK.

Michael

Elfe
Posts: 3
Joined: 16 Mar 2019 17:44

Re: Ubuntu 18 and HELI-X 8

Post by Elfe » 19 Mar 2019 17:48

Hi,

email has been sent.
Just to keep everyone else in the loop the OpenJDK/GFX driver version is identical on both of my PCs.

Karsten

User avatar
Michael
Posts: 1784
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Ubuntu 18 and HELI-X 8

Post by Michael » 19 Mar 2019 19:34

Hello,

if I understand it right, the machine with the single display makes the problem.

- If version 4.2 is running and version >5 not, then it is likely that the drivers of the graphics adapter do not offer everything what is needed. You should try to update he drivers.
- We also found out that not every Java version behaves equally well on some machines. On some computers, using OpenJDK or the Oracle JRE makes a difference. So you might try to use another Java version. It might also be reasonable to try an older java .

I hope that helps,

Michael

Elfe
Posts: 3
Joined: 16 Mar 2019 17:44

Re: Ubuntu 18 and HELI-X 8

Post by Elfe » 21 Mar 2019 12:47

Hi,

after digging around I found https://github.com/LWJGL/lwjgl/issues/128 which requires xrandr to be installed. If it is not installed the posted error message is thrown. https://github.com/LWJGL/lwjgl/blob/46f ... R.java#L72

"xrandr -q" should produce some output and not a command not found error.

On Arch the required package is xorg-xrandr and after installing it the Heli-X startup works as expected on my second PC :)
The startup script could check and abort if xrandr is not available before running Heli-X.

Code: Select all

command -v xrandr >/dev/null 2>&1 || { echo >&2 "xrandr not found. Please install xrandr for your distro"; }
Best regards
Karsten

User avatar
Michael
Posts: 1784
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Ubuntu 18 and HELI-X 8

Post by Michael » 21 Mar 2019 20:01

Thank you for your efforts and sharing then with us.

Michael

Post Reply