1903

Please note your findings. Do not forget to mention your operating system and the revision of the HELI-X version.
User avatar
Michael
Posts: 1789
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: 1903

Post by Michael » 11 Feb 2019 20:27

Brian wrote:
10 Feb 2019 22:27
Dialog "Model Selection" shows some German words after switching from language German to English (e.g. the dialog title). Other dialogs not tested. After restart of HELI-X the problem is fixed. If you cannot guarantee an on-the-fly language selection, you should show a message "You have to restart..." after selection of a new language.
Well, there are only a few problems when the language is changed, and since the language is typically chosen only once, I think I can let it as it is.
Brian wrote:
10 Feb 2019 22:27
Within the "Model Selection" dialog, filtering does not properly work.
If you select "Type: Scale" no planes are shown, they're all listed as "Trainer".

Consider to add the engine type "Turbine".

Filter for "Size" does not show proper results. E.g. "plane; Type: All; Engine: All; Size < 0.6m shows Opterra1_2m which has a wing span of 1.2m.
Size: 0.6-1m shows Opterra with 2m wing span.
Size: 1.5-2m shows DassaultMystere with 2.5m wing span
Size: >2m shows Extra 330, and Trojan which have only 2m wing span
This should work better now. It is a kind of feature that planes with wing span e.g. 2m, are shon in two sets ( < 2m and > 2m).
"Turbine": perhaps later.

User avatar
Michael
Posts: 1789
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: 1903

Post by Michael » 11 Feb 2019 20:34

Brian wrote:
10 Feb 2019 22:42
I've configured a switch for autorotation. In conjunction with planes, switching to autorotation turns off the smoke of the engine, but the prop does not stop spinning. It would be nice, if the engine stops completely, and thrust becomes zero (not reducing idle speed as seen in the status bar).
This is not ideal, indeed. The whole flight phases issue will be rewokred later, so we skip this.

Mike656
Posts: 3
Joined: 05 Feb 2019 20:19

Re: 1903

Post by Mike656 » 11 Feb 2019 21:35

Just loaded 1903 on a MacBook Pro, and the 8 or 9 keys do not zoom in or out. They were working fine on 1900.
macOS Mojave v10.14.2

User avatar
Michael
Posts: 1789
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: 1903

Post by Michael » 11 Feb 2019 21:37

please try to configure them new

Mike656
Posts: 3
Joined: 05 Feb 2019 20:19

Re: 1903

Post by Mike656 » 12 Feb 2019 09:23

Zoom keys working fine now, thanks

User avatar
Brian
Posts: 25
Joined: 19 Dec 2018 23:13

Re: 1903

Post by Brian » 17 Feb 2019 20:23

chrig wrote:
11 Feb 2019 15:01
Brian wrote:
10 Feb 2019 18:44
Some reported issues from former versions are still open. Please comment, if some issues are not applicable, or not possible to fix.
I can confirm the crash issue.
Micheal, for gliders the wind noise is okay. Possibly you can manage to increase the volume of the wind noise for motorized aircrafts if throttle is idle. This would be more realistic, because the engine is normally much louder than the wind noise.
Brain, I would say the wind noise is to loud for motorized aircraft. So I suggest to reduce it!?
Sorry for being vague. I meant louder if throttle is idle, and more silent (nearly not to hear), if throttle isn't idle. I agree, wind noise is too loud.

Post Reply