Page 1 of 1

Connection issues

Posted: 07 May 2018 06:54
by Mehari
I have not used Heli-X for a few years and have recently been trying to start again with the demo version of V7 on my Mac running High Sierra 10.13.4.

Unfortunately I have not yet been able to establish a connection with my transmitter. I have tried with a Spectrum DX7 and an FrSky Horus X12S running OpenTX 2.2.

I am using an old Pre-Flight RC USB connector with a stereo plug connection to the transmitter.

I am not sure if I have a hardware issue (i.e. the USB connector is not compatible) or computer software issue. I have loaded the latest version of Java I could find (2017-001) but to no avail.

Any suggestions welcome.

Re: Connection issues

Posted: 15 May 2018 09:43
by Mehari
Okay. I have dumped the Pre-Flight RC USB connector and now have a 'SuperSimX' adapter which has a switch to select XTR G2 FMS, G4 G5 G6.5, Aerofly and PhoenixRC.

Heli-X now recognises the controller in each of the four switch positions but I am not yet able to complete the controller setup process.

For example, using the XTR option, when I open the Controller Configuration window and select STICKS, there are four items: x, y, z and slider. When I click on NEXT and move to the window to set maximum and minimum stick positions, the horizontal blue bars flicker erratically. When I move the sticks, only one of the blue bars responds. I then get the message "Did not detect 4 channels. Detected 3".

I have tried all of the Global Settings/Inputs options and although the behaviour of each varies a little, none of them produce a stable result that recognises all four sticks.

I would appreciate guidance to sort out this situation.

Re: Connection issues

Posted: 15 May 2018 21:36
by Michael
Try to send on different channels from your transmitter, e.g. switch on a mixer...


Re: Connection issues

Posted: 17 May 2018 09:04
by Mehari
I managed to get things sorted after playing around for a while with transmitter channels and the Input System in Global Settings. The only system that recognised all channels was jinput-b8.jar.

Thanks Michael